<!DOCTYPE html>
<html lang="en">
<head>
<meta charset="UTF-8">
<meta name="viewport" content="width=device-width, initial-scale=1">
<link rel="profile" href="http://gmpg.org/xfn/11">
<link rel="pingback" href="https://arcadeblogger.com/xmlrpc.php">

<title>2017 Review &amp; Free to Watch Arcade Movies! &#8211; The Arcade Blogger</title>
<script type="text/javascript">
  WebFontConfig = {"google":{"families":["Roboto+Slab:r:latin,latin-ext","Ubuntu:r,i,b,bi:latin,latin-ext"]}};
  (function() {
    var wf = document.createElement('script');
    wf.src = 'https://s1.wp.com/wp-content/plugins/custom-fonts/js/webfont.js';
    wf.type = 'text/javascript';
    wf.async = 'true';
    var s = document.getElementsByTagName('script')[0];
    s.parentNode.insertBefore(wf, s);
	})();
</script><style id="jetpack-custom-fonts-css">.wf-active body{font-family:"Ubuntu",sans-serif}.wf-active blockquote{font-family:"Ubuntu",sans-serif}.wf-active blockquote cite{font-family:"Ubuntu",sans-serif}.wf-active code, .wf-active kbd, .wf-active pre, .wf-active tt, .wf-active var{font-family:"Ubuntu",sans-serif}.wf-active pre{font-family:"Ubuntu",sans-serif}.wf-active .menu-toggle{font-family:"Ubuntu",sans-serif}.wf-active .is-singular .post-navigation .nav-links span.nav-subtitle{font-family:"Ubuntu",sans-serif}.wf-active .comments-title .add-comment-link{font-family:"Ubuntu",sans-serif}.wf-active .comment-navigation a{font-family:"Ubuntu",sans-serif}.wf-active .widget-title{font-family:"Ubuntu",sans-serif}.wf-active h1, .wf-active h2, .wf-active h3, .wf-active h4, .wf-active h5, .wf-active h6{font-family:"Roboto Slab",serif;font-weight:400;font-style:normal}.wf-active h1{font-weight:400;font-style:normal}.wf-active h2{font-style:normal;font-weight:400}.wf-active h3{font-style:normal;font-weight:400}.wf-active h4{font-style:normal;font-weight:400}.wf-active h5{font-family:"Roboto Slab",serif;font-style:normal;font-weight:400}.wf-active h6{font-family:"Roboto Slab",serif;font-style:normal;font-weight:400}.wf-active .site-title{font-style:normal;font-weight:400}.wf-active .site-banner h1{font-style:normal;font-weight:400}.wf-active .comment-body h1, .wf-active .entry-content h1{font-style:normal;font-weight:400}.wf-active .page-title h1{font-style:normal;font-weight:400}.wf-active .posts .entry-title{font-weight:400;font-style:normal}.wf-active .author-link, .wf-active .is-singular .post-navigation .nav-links span.nav-title{font-family:"Roboto Slab",serif;font-style:normal;font-weight:400}.wf-active .comments-title{font-style:normal;font-weight:400}.wf-active .widget h1, .wf-active .widget h2, .wf-active .widget h3, .wf-active .widget h4, .wf-active .widget h5, .wf-active .widget h6{font-family:"Roboto Slab",serif;font-style:normal;font-weight:400}.wf-active .is-singular.archive-eventbrite .entry-header h1{font-style:normal;font-weight:400}@media screen and (min-width: 1601px){.wf-active .site-banner h1{font-style:normal;font-weight:400}}@media screen and (max-width: 1400px){.wf-active .site-banner h1{font-style:normal;font-weight:400}}@media screen and (max-width: 1200px){.wf-active .site-banner h1{font-style:normal;font-weight:400}}@media screen and (max-width: 680px){.wf-active .site-banner h1{font-style:normal;font-weight:400}}@media screen and (max-width: 1200px){.wf-active .is-singular .entry-header h1, .wf-active .error404 .entry-header h1, .wf-active .page-header h1, .wf-active .page-template-eventbrite-index .page-header h1, .wf-active .single-event .entry-header h1{font-style:normal;font-weight:400}}@media screen and (max-width: 1200px){.wf-active .is-singular.archive-eventbrite .entry-header h1{font-style:normal;font-weight:400}}@media screen and (max-width: 960px){.wf-active .is-singular:not(.eventbrite-archive) .entry-header h1, .wf-active .error404 .entry-header h1, .wf-active .page-header h1{font-style:normal;font-weight:400}}@media screen and (max-width: 680px){.wf-active .is-singular:not(.eventbrite-archive) .entry-header h1, .wf-active .error404 .entry-header h1, .wf-active .page-header h1, .wf-active .page-template-eventbrite-index .page-header h1, .wf-active .single-event .entry-header h1{font-style:normal;font-weight:400}}@media screen and (max-width: 680px){.wf-active .is-singular.archive-eventbrite .entry-header h1{font-style:normal;font-weight:400}}</style>
<meta name="google-site-verification" content="F8bvTfWeADwcB3BgKNxjZtosFk2eLmlfhWj9ls8mnfw" />
<meta name="msvalidate.01" content="1E938D18629D4730EBB3E35506F1A215" />
<meta name="p:domain_verify" content="b59715e19a7dd742d159be7bbc668716" />
<meta name="yandex-verification" content="30414ca1cf031b76" />
		<script src='https://r-login.wordpress.com/remote-login.php?action=js&amp;host=arcadeblogger.com&amp;id=3810034&amp;t=1514052627&amp;back=https%3A%2F%2Farcadeblogger.com%2F2017%2F12%2F22%2F2017-review-free-to-watch-arcade-movies%2F' type="text/javascript"></script>
		<script type="text/javascript">
		/* <![CDATA[ */
			if ( 'function' === typeof WPRemoteLogin ) {
				document.cookie = "wordpress_test_cookie=test; path=/";
				if ( document.cookie.match( /(;|^)\s*wordpress_test_cookie\=/ ) ) {
					WPRemoteLogin();
				}
			}
		/* ]]> */
		</script>
		<link rel='dns-prefetch' href='//s2.wp.com' />
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//missilecommand.wordpress.com' />
<link rel='dns-prefetch' href='//s1.wp.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel="alternate" type="application/rss+xml" title="The Arcade Blogger &raquo; Feed" href="https://arcadeblogger.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="The Arcade Blogger &raquo; Comments Feed" href="https://arcadeblogger.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="The Arcade Blogger &raquo; 2017 Review &amp; Free to Watch Arcade Movies! Comments Feed" href="https://arcadeblogger.com/2017/12/22/2017-review-free-to-watch-arcade-movies/feed/" />
	<script type="text/javascript">
		/* <![CDATA[ */
		function addLoadEvent(func) {
			var oldonload = window.onload;
			if (typeof window.onload != 'function') {
				window.onload = func;
			} else {
				window.onload = function () {
					oldonload();
					func();
				}
			}
		}
		/* ]]> */
	</script>
			<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s0.wp.com\/wp-content\/mu-plugins\/wpcom-smileys\/twemoji\/2\/72x72\/","ext":".png","svgUrl":"https:\/\/s0.wp.com\/wp-content\/mu-plugins\/wpcom-smileys\/twemoji\/2\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/s2.wp.com\/wp-includes\/js\/wp-emoji-release.min.js?m=1505864856h&ver=4.9.1"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55358,56794,8205,9794,65039],[55358,56794,8203,9794,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='all-css-0-1' href='https://s1.wp.com/_static/??-eJyFj90KwjAMhV/IGqZT3IX4LFsNrlvThqVl+PamDgVF5k3Iz/k4JzCzsTEkDAkoG/b55oLAzDaSEXIe71/T1ops4Dfm3YgCAyZu7Wie05rcxgl1T9ymoiC8uhY9ksrWMOLjiyptr16rNkv8ruMJRYxWcplM6tXoTzwqUZY/QIWfmwV1EGJySsu7KYcLnav60OzqqtmfhgcvXIXW?cssminify=yes' type='text/css' media='all' />
<link rel='stylesheet' id='dyad-2-fonts-css'  href='https://fonts.googleapis.com/css?family=Lato%3A400%2C400italic%2C700%2C700italic%7CNoto+Serif%3A400%2C400italic%2C700%2C700italic&#038;subset=latin%2Clatin-ext' type='text/css' media='all' />
<link rel='stylesheet' id='all-css-2-1' href='https://s1.wp.com/_static/??-eJyNjsEKwjAQRH/Idau06kX8ljRd40qSDd2E0r+30ktELN5mmPdgcEpgJWaKGUOB5IvjqOgo0sjL8CPureoOKzc/KJBiKj0OsxngiJpnT39wHO3KwpSshC+jejXx4Cgrqlg2HtZTddmSHQl4sSazxI8Cd2943FJH6r24JTpcqKq+pVu4HrrmfOlObds8X1prfPk=?cssminify=yes' type='text/css' media='all' />
<style id='dyad-2-style-inline-css' type='text/css'>
.posted-on, .tags-links, .byline, .date-published-word { clip: rect(1px, 1px, 1px, 1px); height: 1px; position: absolute; overflow: hidden; width: 1px; }
</style>
<link rel='stylesheet' id='print-css-3-1' href='https://s0.wp.com/wp-content/mu-plugins/global-print/global-print.css?m=1465851035h&cssminify=yes' type='text/css' media='print' />
<link rel='stylesheet' id='all-css-4-1' href='https://s2.wp.com/_static/??-eJx9i9EKwjAMRX/IGoVN54P4LVnp2kialCbD3xcfRGTi0z0XzoFHC1HFkzjUNTReM4kBRieVGfuH9tFsB7/1puZhYaQOVrCT5Pf+q0wjIQfWrN9nE3lJNRmUATLrjPwSbvV6HC6H83Qap/H+BMWZScE=?cssminify=yes' type='text/css' media='all' />
<script type='text/javascript' src='https://s1.wp.com/_static/??-eJyFztEKwjAMBdAfsquTiXsRv6XWOFKXtDbphn69HeiDMBQCgdzDJXZOBtmP5QJiQ517gfx4rybIxv4ChnDITqEh5A/2kRVYF0vxjCOYIpDdUG+16BpXXIqiBCIVraTfLyFPCPNfFkCT8zeTQfC5tJ7o2Hb9Yde3+24bXjRNW9I='></script>
<link rel='stylesheet' id='all-css-0-2' href='https://s1.wp.com/wp-content/mu-plugins/highlander-comments/style.css?m=1377793621h&cssminify=yes' type='text/css' media='all' />
<!--[if lt IE 8]>
<link rel='stylesheet' id='highlander-comments-ie7-css'  href='https://s1.wp.com/wp-content/mu-plugins/highlander-comments/style-ie7.css?m=1351637563h&#038;ver=20110606' type='text/css' media='all' />
<![endif]-->
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://missilecommand.wordpress.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://s1.wp.com/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='Arcade Raid! The Mississippi Screwjob' href='https://arcadeblogger.com/2017/12/15/arcade-raid-the-mississippi-screwjob/' />
<meta name="generator" content="WordPress.com" />
<link rel="canonical" href="https://arcadeblogger.com/2017/12/22/2017-review-free-to-watch-arcade-movies/" />
<link rel='shortlink' href='https://wp.me/pfZaa-667' />
<link rel="alternate" type="application/json+oembed" href="https://public-api.wordpress.com/oembed/?format=json&amp;url=https%3A%2F%2Farcadeblogger.com%2F2017%2F12%2F22%2F2017-review-free-to-watch-arcade-movies%2F&amp;for=wpcom-auto-discovery" /><link rel="alternate" type="application/xml+oembed" href="https://public-api.wordpress.com/oembed/?format=xml&amp;url=https%3A%2F%2Farcadeblogger.com%2F2017%2F12%2F22%2F2017-review-free-to-watch-arcade-movies%2F&amp;for=wpcom-auto-discovery" />
<!-- Jetpack Open Graph Tags -->
<meta property="og:type" content="article" />
<meta property="og:title" content="2017 Review &amp; Free to Watch Arcade Movies!" />
<meta property="og:url" content="https://arcadeblogger.com/2017/12/22/2017-review-free-to-watch-arcade-movies/" />
<meta property="og:description" content="As 2017 draws to a close, I thought some reflection this week would be in order. It&#8217;s been another great year for the site with visitor numbers in the hundreds of thousands for the second yea…" />
<meta property="article:published_time" content="2017-12-22T17:13:18+00:00" />
<meta property="article:modified_time" content="2017-12-22T22:40:43+00:00" />
<meta property="og:site_name" content="The Arcade Blogger" />
<meta property="og:image" content="https://missilecommand.files.wordpress.com/2017/12/xmas-tempest-greeting1.jpg" />
<meta property="og:image:width" content="711" />
<meta property="og:image:height" content="900" />
<meta property="og:locale" content="en_US" />
<meta name="twitter:site" content="@arcadeblogger" />
<meta name="twitter:text:title" content="2017 Review &amp; Free to Watch Arcade Movies!" />
<meta name="twitter:image:src" content="https://missilecommand.files.wordpress.com/2017/12/xmas-tempest-greeting1.jpg?w=640" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:creator" content="@arcadeblogger" />
<meta property="article:publisher" content="https://www.facebook.com/WordPresscom" />
<link rel="shortcut icon" type="image/x-icon" href="https://secure.gravatar.com/blavatar/b7892ea414bb17d4568669c49151505c?s=32" sizes="16x16" />
<link rel="icon" type="image/x-icon" href="https://secure.gravatar.com/blavatar/b7892ea414bb17d4568669c49151505c?s=32" sizes="16x16" />
<link rel="apple-touch-icon-precomposed" href="https://secure.gravatar.com/blavatar/b7892ea414bb17d4568669c49151505c?s=114" />
<link rel='openid.server' href='https://missilecommand.wordpress.com/?openidserver=1' />
<link rel='openid.delegate' href='https://missilecommand.wordpress.com/' />
<link rel="search" type="application/opensearchdescription+xml" href="https://arcadeblogger.com/osd.xml" title="The Arcade Blogger" />
<link rel="search" type="application/opensearchdescription+xml" href="https://s1.wp.com/opensearch.xml" title="WordPress.com" />
<meta name="application-name" content="The Arcade Blogger" /><meta name="msapplication-window" content="width=device-width;height=device-height" /><meta name="msapplication-tooltip" content="By Tony Temple" /><meta name="msapplication-task" content="name=Subscribe;action-uri=https://arcadeblogger.com/feed/;icon-uri=https://secure.gravatar.com/blavatar/b7892ea414bb17d4568669c49151505c?s=16" /><meta name="msapplication-task" content="name=Sign up for a free blog;action-uri=http://wordpress.com/signup/;icon-uri=https://s2.wp.com/i/favicon.ico" /><meta name="msapplication-task" content="name=WordPress.com Support;action-uri=http://support.wordpress.com/;icon-uri=https://s2.wp.com/i/favicon.ico" /><meta name="msapplication-task" content="name=WordPress.com Forums;action-uri=http://forums.wordpress.com/;icon-uri=https://s2.wp.com/i/favicon.ico" /><meta name="title" content="2017 Review &amp; Free to Watch Arcade Movies! | The Arcade Blogger on WordPress.com" />
<meta name="description" content="As 2017 draws to a close, I thought some reflection this week would be in order. It&#039;s been another great year for the site with visitor numbers in the hundreds of thousands for the second year running. For a site like this, covering such a niche subject matter, the level of support has been fantastic&hellip;" />
<link rel="amphtml" href="https://arcadeblogger.com/2017/12/22/2017-review-free-to-watch-arcade-movies/amp/" /><style type="text/css" id="syntaxhighlighteranchor"></style>
		<link rel="stylesheet" id="custom-css-css" type="text/css" href="https://s1.wp.com/?custom-css=1&#038;csblog=fZaa&#038;cscache=6&#038;csrev=36" />
		</head>

<body class="post-template-default single single-post postid-23443 single-format-standard mp6 customizer-styles-applied is-singular has-post-thumbnail no-js date-hidden tags-hidden author-hidden highlander-enabled highlander-light">
<div id="page" class="hfeed site">
	<a class="skip-link screen-reader-text" href="#content">Skip to content</a>

	<header id="masthead" class="site-header" role="banner">
		<div class="site-branding">
						<h1 class="site-title">
				<a href="https://arcadeblogger.com/" rel="home">
					The Arcade Blogger				</a>
			</h1>
			<p class="site-description">By Tony Temple</p>
		</div><!-- .site-branding -->

		<nav id="site-navigation" class="main-navigation" role="navigation">
			<button class="menu-toggle" aria-controls="primary-menu" aria-expanded="false">Menu</button>
			<div class="primary-menu"><ul id="primary-menu" class="menu"><li id="menu-item-76" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-76"><a href="https://arcadeblogger.com/about/">About/Contact</a></li>
<li id="menu-item-3644" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-3644"><a href="https://arcadeblogger.com/category/article/">Arcade Articles</a>
<ul class="sub-menu">
	<li id="menu-item-19112" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-19112"><a href="https://arcadeblogger.com/tag/Arcade-Raid/?order=asc">Arcade Raids</a></li>
</ul>
</li>
<li id="menu-item-2640" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-2640"><a href="https://arcadeblogger.com/category/restoration/">Restoration Archive</a>
<ul class="sub-menu">
	<li id="menu-item-2681" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-2681"><a href="https://arcadeblogger.com/tag/Asteroids-Restoration/?order=asc">Asteroids Cabaret</a></li>
	<li id="menu-item-10492" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-10492"><a href="https://arcadeblogger.com/tag/Battlezone-Cabaret-Restoration/?order=asc">Battlezone Cabaret</a></li>
	<li id="menu-item-2678" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-2678"><a href="https://arcadeblogger.com/tag/Centipede-Restoration/?order=asc">Centipede Cabaret</a></li>
	<li id="menu-item-5773" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5773"><a href="https://arcadeblogger.com/tag/Centipede-Upright-Restoration/?order=asc">Centipede Upright</a></li>
	<li id="menu-item-21236" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-21236"><a href="https://arcadeblogger.com/tag/Cosmic-Guerilla-Restoration/?order=asc">Cosmic Guerilla Upright</a></li>
	<li id="menu-item-2677" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-2677"><a href="https://arcadeblogger.com/tag/Dino-King-Conversion/?order=asc">Dino King Mini</a></li>
	<li id="menu-item-2680" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-2680"><a href="https://arcadeblogger.com/tag/Donkey-Kong-Restoration/?order=asc">Donkey Kong Upright</a></li>
	<li id="menu-item-19111" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-19111"><a href="https://arcadeblogger.com/tag/Gravitar-Restoration/?order=asc">Gravitar Upright</a></li>
	<li id="menu-item-3335" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-3335"><a href="https://arcadeblogger.com/tag/Robotron-Restoration/?order=asc">Robotron Cabaret</a></li>
	<li id="menu-item-2679" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-2679"><a href="https://arcadeblogger.com/tag/Space-Fever-Restoration/?order=asc">Space Fever Cocktail</a></li>
	<li id="menu-item-2676" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-2676"><a href="https://arcadeblogger.com/tag/Tempest-Restoration/?order=asc">Tempest Cabaret</a></li>
</ul>
</li>
<li id="menu-item-789" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-789"><a href="https://arcadeblogger.com/category/missile-command/">Missile Command</a></li>
</ul></div>		</nav>

	</header><!-- #masthead -->

	<div class="site-inner">

		
		<div id="content" class="site-content">

	<main id="primary" class="content-area" role="main">

		
			
<article id="post-23443" class="post-23443 post type-post status-publish format-standard has-post-thumbnail hentry category-article tag-arcade tag-chasing-ghosts tag-christmas tag-classic-arcade tag-classic-arcade-games tag-king-of-kong tag-retrogaming tag-video-games">
			
		<div class="entry-media" style="background-image: url(https://missilecommand.files.wordpress.com/2017/12/xmas-tempest-greeting1.jpg?w=711&#038;h=900&#038;crop=1)">
			<div class="entry-media-thumb" style="background-image: url(https://missilecommand.files.wordpress.com/2017/12/xmas-tempest-greeting1.jpg?w=711&#038;h=640&#038;crop=1); "></div>
		</div><!-- .entry-media -->
	

	<div class="entry-inner">

		<header class="entry-header">
			<div class="entry-meta">
				<span class="cat-links"><a href="https://arcadeblogger.com/category/article/" rel="category tag">Article</a></span>			</div><!-- .entry-meta -->

			<h1 class="entry-title">2017 Review &amp; Free to Watch Arcade Movies!</h1>
			<div class="entry-posted">
				<div class="posted-info"><span class="byline">Posted by <span class="author vcard"><a class="url fn n" href="https://arcadeblogger.com/author/missilecommand/">Tony</a></span></span><span class="posted-on"> <span class="date-published-word">on</span> <a href="https://arcadeblogger.com/2017/12/22/2017-review-free-to-watch-arcade-movies/" rel="bookmark"><time class="entry-date published" datetime="2017-12-22T17:13:18+00:00">December 22, 2017</time><time class="updated" datetime="2017-12-22T22:40:43+00:00">December 22, 2017</time></a></span></div>			</div><!-- .entry-posted -->
		</header><!-- .entry-header -->

		<div class="entry-content">
			<p>As 2017 draws to a close, I thought some reflection this week would be in order.</p>
<p>It&#8217;s been another great year for the site with visitor numbers in the hundreds of thousands for the second year running. For a site like this, covering such a niche subject matter, the level of support has been fantastic from both arcade enthusiasts, and casual visitors just looking for a good read. It&#8217;s always been my intention to make the subject matter as accessible as possible to anyone visiting the site, so thank you all for your support over the last twelve months.</p>
<p><img data-attachment-id="23524" data-permalink="https://arcadeblogger.com/2017/12/22/2017-review-free-to-watch-arcade-movies/xmas-tempest-greeting-2/" data-orig-file="https://missilecommand.files.wordpress.com/2017/12/xmas-tempest-greeting1.jpg?w=411&#038;h=520" data-orig-size="711,900" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;1513533604&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="XMAS TEMPEST GREETING" data-image-description="" data-medium-file="https://missilecommand.files.wordpress.com/2017/12/xmas-tempest-greeting1.jpg?w=411&#038;h=520?w=237" data-large-file="https://missilecommand.files.wordpress.com/2017/12/xmas-tempest-greeting1.jpg?w=411&#038;h=520?w=711" class="  wp-image-23524 aligncenter" src="https://missilecommand.files.wordpress.com/2017/12/xmas-tempest-greeting1.jpg?w=411&#038;h=520" alt="XMAS TEMPEST GREETING" width="411" height="520" srcset="https://missilecommand.files.wordpress.com/2017/12/xmas-tempest-greeting1.jpg?w=411&amp;h=520 411w, https://missilecommand.files.wordpress.com/2017/12/xmas-tempest-greeting1.jpg?w=76&amp;h=96 76w, https://missilecommand.files.wordpress.com/2017/12/xmas-tempest-greeting1.jpg?w=237&amp;h=300 237w, https://missilecommand.files.wordpress.com/2017/12/xmas-tempest-greeting1.jpg 711w" sizes="(max-width: 411px) 100vw, 411px" /></p>
<p>If you&#8217;re interested, here are the top 5 articles on the site based on page views since January 2017:</p>
<ol>
<li><a href="https://arcadeblogger.com/2017/09/15/arcade-raid-abandoned-house-vive-la-france/" target="_blank" rel="noopener">Arcade Raid! Abandoned House: Vive la France!</a></li>
<li><a href="https://arcadeblogger.com/2017/01/20/centuri-aztarac-finding-the-holy-arcade-grail/" target="_blank" rel="noopener">Centuri Aztarac: Finding THE Holy Arcade Grail&#8230;</a></li>
<li><a href="https://arcadeblogger.com/2017/08/25/atari-ireland/" target="_blank" rel="noopener">Atari Ireland: Tipperary&#8217;s Arcade Connection</a></li>
<li><a href="https://arcadeblogger.com/2017/06/02/gdis-slither-the-1-3-million-dollar-crash-burn/" target="_blank" rel="noopener">GDI&#8217;s Slither: The $1.3 Million Crash &amp; Burn</a></li>
<li><a href="https://arcadeblogger.com/2017/04/21/the-atari-arcade-theatre-kiosk/" target="_blank" rel="noopener">The Atari Arcade Theatre Kiosk</a></li>
</ol>
<p>So if you missed any of those first time round, or need an excuse to avoid the in-laws over the Xmas break, do check them out. There&#8217;s well over 140 articles now on the blog &#8211; have a trawl through the archives using the menus at the top of this page.</p>
<p>And as it&#8217;s Christmas, I&#8217;m sure you&#8217;ll have some spare time on your hands, so I thought I&#8217;d share a couple of arcade movies that are available to watch for free on YouTube.</p>
<p><em>King of Kong</em> I&#8217;m sure most of you have already seen at some point &#8211; this film was a huge hit, and for many people, brought the classic arcade scene into the spotlight like never before. It&#8217;s a been a few years since I watched it, and is definitely worth another look. The film has been dissected to death over the years, but as a story and a piece of light entertainment it still holds its own. So sit the family down and give yourself a refresher of the ins and out of the Donkey Kong scene as it was back in 2005/6:</p>
<div class="jetpack-video-wrapper"><span class="embed-youtube" style="text-align:center; display: block;"><iframe class='youtube-player' type='text/html' width='1000' height='593' src='https://www.youtube.com/embed/_4v15X8Px34?version=3&#038;rel=1&#038;fs=1&#038;autohide=2&#038;showsearch=0&#038;showinfo=1&#038;iv_load_policy=1&#038;wmode=transparent' allowfullscreen='true' style='border:0;'></iframe></span></div>
<p>And then there&#8217;s <em>Chasing Ghosts</em> released around the same time, which I think got unfairly lost in the hype surrounding King Of Kong, but it has a certain charm about it, and focuses more on personalities and people rather than the story-based drama of <em>KoK</em>:</p>
<div class="jetpack-video-wrapper"><span class="embed-youtube" style="text-align:center; display: block;"><iframe class='youtube-player' type='text/html' width='1000' height='593' src='https://www.youtube.com/embed/X-RgSvWJOos?version=3&#038;rel=1&#038;fs=1&#038;autohide=2&#038;showsearch=0&#038;showinfo=1&#038;iv_load_policy=1&#038;wmode=transparent' allowfullscreen='true' style='border:0;'></iframe></span></div>
<p>And then there&#8217;s this series of films, <em>The Rise of the Video Game</em>, which document the rise of video games over the years. I&#8217;ve linked here to the first episode in the series, as that has plenty of cool info relating to the early days of video arcade games. YouTube will suggest the other 3 in the series if you want to keep going. I thought it was well done and is worth 40 minutes of your time:</p>
<div class="jetpack-video-wrapper"><span class="embed-youtube" style="text-align:center; display: block;"><iframe class='youtube-player' type='text/html' width='1000' height='593' src='https://www.youtube.com/embed/3u3Hc13wzHE?version=3&#038;rel=1&#038;fs=1&#038;autohide=2&#038;showsearch=0&#038;showinfo=1&#038;iv_load_policy=1&#038;wmode=transparent' allowfullscreen='true' style='border:0;'></iframe></span></div>
<p>Let us know what you think of any of those three in the comments section below.</p>
<p>I also came across this today. It&#8217;s brilliant, and I&#8217;m sure every word rings true to you USA based collectors. Funny stuff:</p>
<div class="jetpack-video-wrapper"><span class="embed-youtube" style="text-align:center; display: block;"><iframe class='youtube-player' type='text/html' width='1000' height='593' src='https://www.youtube.com/embed/G59TII3KWrA?version=3&#038;rel=1&#038;fs=1&#038;autohide=2&#038;showsearch=0&#038;showinfo=1&#038;iv_load_policy=1&#038;wmode=transparent' allowfullscreen='true' style='border:0;'></iframe></span></div>
<p>Anyway &#8211; as for next year, well without giving away too much, I already have plenty of great things lined up including new and old arcade raids, reviews of arcades, new arcade articles based on documents prized from the Atari archives, and of course some new restorations, <a href="https://arcadeblogger.com/2017/06/09/williams-robotron-weekend-pickup/" target="_blank" rel="noopener">including the <em>Robotron</em> I picked up earlier this year</a> which I&#8217;ll be making a start on very soon. I&#8217;ll also have some details to share with you about the book I&#8217;m in the process of writing, which I hope to complete later in the year.</p>
<p>And while I&#8217;m here &#8211; if there&#8217;s something specific you want me to write about, or indeed if you have a cool arcade-related story you&#8217;d like me to write up and share with the world, leave a comment below or drop me a line using the <em>Contact</em> menu at the top of this page.</p>
<p>So stay tuned &#8211; as always, I&#8217;ll continue to update the site with something new every week. If you haven&#8217;t already subscribed to the blog, you can do so below. Enter your email address and you&#8217;ll get a notification whenever a new article is published here on Arcade Blogger.</p>
<p>I&#8217;ll be taking a two-week break over the festive period, so for now I&#8217;ll wish you and your families a great Christmas and a happy New Year. See you in 2018!</p>
<p>Tony</p>
<div class="widget widget_blog_subscription"><h2 class="widgettitle"><label for="subscribe-field">Follow Blog via Email</label></h2>
				<form action="https://subscribe.wordpress.com" method="post" accept-charset="utf-8" id="subscribe-blog">
											<p>Enter your email address to follow this blog and receive notifications of new posts by email.</p>
						<p><input type="text" name="email" style="width: 95%; padding: 1px 2px" placeholder="Enter your email address" value="" id="subscribe-field"/></p>
					
					<p>
						<input type="hidden" name="action" value="subscribe"/>
						<input type="hidden" name="blog_id" value="3810034"/>
						<input type="hidden" name="source" value="https://arcadeblogger.com/2017/12/22/2017-review-free-to-watch-arcade-movies/"/>
						<input type="hidden" name="sub-type" value="widget"/>
						<input type="hidden" name="redirect_fragment" value="" />
						<input type="hidden" id="_wpnonce" name="_wpnonce" value="e7291e5af0" />						<input type="submit" value="Follow" />
					</p>
				</form>
			
</div>
<div id="jp-post-flair" class="sharedaddy sd-like-enabled sd-sharing-enabled"><div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-official sd-sharing"><h3 class="sd-title">Share this article!</h3><div class="sd-content"><ul><li class="share-facebook"><div class="fb-share-button" data-href="https://arcadeblogger.com/2017/12/22/2017-review-free-to-watch-arcade-movies/" data-layout="button_count"></div></li><li class="share-twitter"><a href="https://twitter.com/share" class="twitter-share-button" data-url="https://arcadeblogger.com/2017/12/22/2017-review-free-to-watch-arcade-movies/" data-text="2017 Review &amp; Free to Watch Arcade Movies!" data-via="arcadeblogger" data-related="wordpressdotcom">Tweet</a></li><li class="share-reddit"><div class="reddit_button"><iframe src="https://www.reddit.com/static/button/button1.html?width=120&amp;url=https%3A%2F%2Farcadeblogger.com%2F2017%2F12%2F22%2F2017-review-free-to-watch-arcade-movies%2F&amp;title=2017%20Review%20%26%20Free%20to%20Watch%20Arcade%20Movies%21" height="22" width="120" scrolling="no" frameborder="0"></iframe></div></li><li class="share-tumblr"><a target="_blank" href="http://www.tumblr.com/share/link/?url=https%3A%2F%2Farcadeblogger.com%2F2017%2F12%2F22%2F2017-review-free-to-watch-arcade-movies%2F&name=2017%20Review%20%26%20Free%20to%20Watch%20Arcade%20Movies%21" title="Share on Tumblr" style="display:inline-block; text-indent:-9999px; overflow:hidden; width:62px; height:20px; background:url('//platform.tumblr.com/v1/share_2.png') top left no-repeat transparent;">Share on Tumblr</a></li><li class="share-pinterest"><div class="pinterest_button"><a href="//www.pinterest.com/pin/create/button/?url=https%3A%2F%2Farcadeblogger.com%2F2017%2F12%2F22%2F2017-review-free-to-watch-arcade-movies%2F&#038;media=https%3A%2F%2Fmissilecommand.files.wordpress.com%2F2017%2F12%2Fxmas-tempest-greeting1.jpg&#038;description=2017%20Review%20%26amp%3B%20Free%20to%20Watch%20Arcade%20Movies%21" data-pin-do="buttonPin" data-pin-config="beside"><img src="//assets.pinterest.com/images/pidgets/pinit_fg_en_rect_gray_20.png" /></a></div></li><li class="share-end"></li></ul></div></div></div><div class='sharedaddy sd-block sd-like jetpack-likes-widget-wrapper jetpack-likes-widget-unloaded' id='like-post-wrapper-3810034-23443-5a3e9c1322ed0' data-src='//widgets.wp.com/likes/#blog_id=3810034&amp;post_id=23443&amp;origin=missilecommand.wordpress.com&amp;obj_id=3810034-23443-5a3e9c1322ed0' data-name='like-post-frame-3810034-23443-5a3e9c1322ed0'><h3 class='sd-title'>Like this:</h3><div class='likes-widget-placeholder post-likes-widget-placeholder' style='height: 55px;'><span class='button'><span>Like</span></span> <span class="loading">Loading...</span></div><span class='sd-text-color'></span><a class='sd-link-color'></a></div></div>					</div><!-- .entry-content -->

		<footer class="entry-footer"><div class="tags-links"><a href="https://arcadeblogger.com/tag/arcade/" rel="tag">arcade</a><a href="https://arcadeblogger.com/tag/chasing-ghosts/" rel="tag">Chasing Ghosts</a><a href="https://arcadeblogger.com/tag/christmas/" rel="tag">Christmas</a><a href="https://arcadeblogger.com/tag/classic-arcade/" rel="tag">classic arcade</a><a href="https://arcadeblogger.com/tag/classic-arcade-games/" rel="tag">classic arcade games</a><a href="https://arcadeblogger.com/tag/king-of-kong/" rel="tag">King of Kong</a><a href="https://arcadeblogger.com/tag/retrogaming/" rel="tag">retrogaming</a><a href="https://arcadeblogger.com/tag/video-games/" rel="tag">video games</a></div></footer>
			</div><!-- .entry-inner -->
</article><!-- #post-## -->


			
	<nav class="navigation post-navigation" role="navigation">
		<h2 class="screen-reader-text">Post navigation</h2>
		<div class="nav-links"><div class="nav-previous"><a href="https://arcadeblogger.com/2017/12/15/arcade-raid-the-mississippi-screwjob/" rel="prev"><div class="nav-previous"><span class="nav-subtitle">Previous Post</span> <span class="nav-title">Arcade Raid! The Mississippi Screwjob</span></div></a></div></div>
	</nav>
		
		
<div class="comments-area-wrapper">

	<div id="comments" class="comments-area">

		
		
		
			<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/2017/12/22/2017-review-free-to-watch-arcade-movies/#respond" style="display:none;">Cancel reply</a></small></h3>			<form action="https://arcadeblogger.com/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate>
				<input type="hidden" id="highlander_comment_nonce" name="highlander_comment_nonce" value="1dbc4d39d4" /><input type="hidden" name="_wp_http_referer" value="/2017/12/22/2017-review-free-to-watch-arcade-movies/" />
<input type="hidden" name="hc_post_as" id="hc_post_as" value="guest" />

<div class="comment-form-field comment-textarea">
	<label for="comment">Enter your comment here...</label>
	<div id="comment-form-comment"><textarea id="comment" name="comment" title="Enter your comment here..."></textarea></div>
</div>

<div id="comment-form-identity">

	<div id="comment-form-nascar">
		<p>Fill in your details below or click an icon to log in:</p>
		<ul>
			<li class="selected" style="display:none;">
				<a href="#comment-form-guest" id="postas-guest" title="Guest">
					<span></span>
				</a>
			</li>
			<li>
				<a href="#comment-form-load-service:WordPress.com" id="postas-wordpress" title="WordPress.com">
					<span></span>
				</a>
			</li>
			<li>
				<a href="#comment-form-load-service:Twitter" id="postas-twitter" title="Twitter">
					<span></span>
				</a>
			</li>
			<li>
				<a href="#comment-form-load-service:Facebook" id="postas-facebook" title="Facebook">
					<span></span>
				</a>
			</li>
			<li>
		</ul>
	</div>

	<div id="comment-form-guest" class="comment-form-service selected">
		<div class="comment-form-padder">
			<div class="comment-form-avatar">
<a href="https://gravatar.com/site/signup/" target="_blank">				<img src="https://1.gravatar.com/avatar/ad516503a11cd5ca435acc9bb6523536?s=25&amp;d=identicon&amp;forcedefault=y" alt="Gravatar" width="25" class="no-grav" />
</a>			</div>

				<div class="comment-form-fields">
				<div class="comment-form-field comment-form-email">
					<label for="email">Email <span class="required">(required)</span> <span class="nopublish">(Address never made public)</span></label>
					<div class="comment-form-input"><input id="email" name="email" type="email" value="" /></div>
				</div>
				<div class="comment-form-field comment-form-author">
					<label for="author">Name <span class="required">(required)</span></label>
					<div class="comment-form-input"><input id="author" name="author" type="text" value="" /></div>
				</div>
				<div class="comment-form-field comment-form-url">
					<label for="url">Website</label>
					<div class="comment-form-input"><input id="url" name="url" type="url" value="" /></div>
				</div>
			</div>
	
		</div>
	</div>

	<div id="comment-form-wordpress" class="comment-form-service">
		<div class="comment-form-padder">
			<div class="comment-form-avatar">
				<img src="https://1.gravatar.com/avatar/ad516503a11cd5ca435acc9bb6523536?s=25&amp;d=identicon&amp;forcedefault=y" alt="WordPress.com Logo" width="25" class="no-grav" />
			</div>

				<div class="comment-form-fields">
				<input type="hidden" name="wp_avatar" id="wordpress-avatar" class="comment-meta-wordpress" value="" />
				<input type="hidden" name="wp_user_id" id="wordpress-user_id" class="comment-meta-wordpress" value="" />
				<input type="hidden" name="wp_access_token" id="wordpress-access_token" class="comment-meta-wordpress" value="" />
				<p class="comment-form-posting-as pa-wordpress"><strong></strong> You are commenting using your WordPress.com account. <span class="comment-form-log-out">(&nbsp;<a href="javascript:HighlanderComments.doExternalLogout( 'wordpress' );">Log&nbsp;Out</a>&nbsp;/&nbsp;<a href="#" onclick="javascript:HighlanderComments.switchAccount();return false;">Change</a>&nbsp;)</span></p>
			</div>
	
		</div>
	</div>

	<div id="comment-form-twitter" class="comment-form-service">
		<div class="comment-form-padder">
			<div class="comment-form-avatar">
				<img src="https://1.gravatar.com/avatar/ad516503a11cd5ca435acc9bb6523536?s=25&amp;d=identicon&amp;forcedefault=y" alt="Twitter picture" width="25" class="no-grav" />
			</div>

				<div class="comment-form-fields">
				<input type="hidden" name="twitter_avatar" id="twitter-avatar" class="comment-meta-twitter" value="" />
				<input type="hidden" name="twitter_user_id" id="twitter-user_id" class="comment-meta-twitter" value="" />
				<input type="hidden" name="twitter_access_token" id="twitter-access_token" class="comment-meta-twitter" value="" />
				<p class="comment-form-posting-as pa-twitter"><strong></strong> You are commenting using your Twitter account. <span class="comment-form-log-out">(&nbsp;<a href="javascript:HighlanderComments.doExternalLogout( 'twitter' );">Log&nbsp;Out</a>&nbsp;/&nbsp;<a href="#" onclick="javascript:HighlanderComments.switchAccount();return false;">Change</a>&nbsp;)</span></p>
			</div>
	
		</div>
	</div>

	<div id="comment-form-facebook" class="comment-form-service">
		<div class="comment-form-padder">
			<div class="comment-form-avatar">
				<img src="https://1.gravatar.com/avatar/ad516503a11cd5ca435acc9bb6523536?s=25&amp;d=identicon&amp;forcedefault=y" alt="Facebook photo" width="25" class="no-grav" />
			</div>

				<div class="comment-form-fields">
				<input type="hidden" name="fb_avatar" id="facebook-avatar" class="comment-meta-facebook" value="" />
				<input type="hidden" name="fb_user_id" id="facebook-user_id" class="comment-meta-facebook" value="" />
				<input type="hidden" name="fb_access_token" id="facebook-access_token" class="comment-meta-facebook" value="" />
				<p class="comment-form-posting-as pa-facebook"><strong></strong> You are commenting using your Facebook account. <span class="comment-form-log-out">(&nbsp;<a href="javascript:HighlanderComments.doExternalLogout( 'facebook' );">Log&nbsp;Out</a>&nbsp;/&nbsp;<a href="#" onclick="javascript:HighlanderComments.switchAccount();return false;">Change</a>&nbsp;)</span></p>
			</div>
	
		</div>
	</div>

	<div id="comment-form-googleplus" class="comment-form-service">
		<div class="comment-form-padder">
			<div class="comment-form-avatar">
				<img src="https://1.gravatar.com/avatar/ad516503a11cd5ca435acc9bb6523536?s=25&amp;d=identicon&amp;forcedefault=y" alt="Google+ photo" width="25" class="no-grav" />
			</div>

				<div class="comment-form-fields">
				<input type="hidden" name="googleplus_avatar" id="googleplus-avatar" class="comment-meta-googleplus" value="" />
				<input type="hidden" name="googleplus_user_id" id="googleplus-user_id" class="comment-meta-googleplus" value="" />
				<input type="hidden" name="googleplus_access_token" id="googleplus-access_token" class="comment-meta-googleplus" value="" />
				<p class="comment-form-posting-as pa-googleplus"><strong></strong> You are commenting using your Google+ account. <span class="comment-form-log-out">(&nbsp;<a href="javascript:HighlanderComments.doExternalLogout( 'googleplus' );">Log&nbsp;Out</a>&nbsp;/&nbsp;<a href="#" onclick="javascript:HighlanderComments.switchAccount();return false;">Change</a>&nbsp;)</span></p>
			</div>
	
		</div>
	</div>


	<div id="comment-form-load-service" class="comment-form-service">
		<div class="comment-form-posting-as-cancel"><a href="javascript:HighlanderComments.cancelExternalWindow();">Cancel</a></div>
		<p>Connecting to %s</p>
	</div>

</div>

<script type="text/javascript">
var highlander_expando_javascript = function(){
	var input = document.createElement( 'input' ),
	    comment = jQuery( '#comment' );

	if ( 'placeholder' in input ) {
		comment.attr( 'placeholder', jQuery( '.comment-textarea label' ).remove().text() );
	}

	// Expando Mode: start small, then auto-resize on first click + text length
	jQuery( '#comment-form-identity' ).hide();
	jQuery( '#comment-form-subscribe' ).hide();
	jQuery( '#commentform .form-submit' ).hide();

	comment.css( { 'height':'10px' } ).one( 'focus', function() {
		var timer = setInterval( HighlanderComments.resizeCallback, 10 )
		jQuery( this ).animate( { 'height': HighlanderComments.initialHeight } ).delay( 100 ).queue( function(n) { clearInterval( timer ); HighlanderComments.resizeCallback(); n(); } );
		jQuery( '#comment-form-identity' ).slideDown();
		jQuery( '#comment-form-subscribe' ).slideDown();
		jQuery( '#commentform .form-submit' ).slideDown();
	});
}
jQuery(document).ready( highlander_expando_javascript );
</script>

<div id="comment-form-subscribe">
	<p class="comment-subscription-form"><input type="checkbox" name="subscribe" id="subscribe" value="subscribe" style="width: auto;"/> <label class="subscribe-label" id="subscribe-label" for="subscribe" style="display: inline;">Notify me of new comments via email.</label></p></div>




<p class="form-submit"><input name="submit" type="submit" id="comment-submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='23443' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="1981cbee7e" /></p>
<input type="hidden" name="genseq" value="1514052627" />
<p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="87"/></p>			</form>
			</div><!-- #respond -->
	<div style="clear: both"></div>
	</div><!-- #comments -->
</div><!-- .comments-area-wrapper -->

	</main><!-- #primary -->


		</div><!-- #content -->

		<footer id="colophon" class="site-footer" role="contentinfo">
			
			<div class="footer-bottom-info ">

				
				<div class="site-info">
					<a href="https://wordpress.com/?ref=footer_custom_svg" title="Create a website or blog at WordPress.com"><svg style="fill: currentColor; position: relative; top: 1px;" width="14px" height="15px" viewBox="0 0 14 15" version="1.1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" aria-labelledby="title" role="img">
				<desc id="title">Create a website or blog at WordPress.com</desc>
				<path d="M12.5225848,4.97949746 C13.0138466,5.87586309 13.2934037,6.90452431 13.2934037,7.99874074 C13.2934037,10.3205803 12.0351007,12.3476807 10.1640538,13.4385638 L12.0862862,7.88081544 C12.4453251,6.98296834 12.5648813,6.26504621 12.5648813,5.62667922 C12.5648813,5.39497674 12.549622,5.17994084 12.5225848,4.97949746 L12.5225848,4.97949746 Z M7.86730089,5.04801561 C8.24619178,5.02808979 8.58760099,4.98823815 8.58760099,4.98823815 C8.9267139,4.94809022 8.88671369,4.44972248 8.54745263,4.46957423 C8.54745263,4.46957423 7.52803983,4.54957381 6.86996227,4.54957381 C6.25158863,4.54957381 5.21247202,4.46957423 5.21247202,4.46957423 C4.87306282,4.44972248 4.83328483,4.96816418 5.17254589,4.98823815 C5.17254589,4.98823815 5.49358462,5.02808979 5.83269753,5.04801561 L6.81314716,7.73459399 L5.43565839,11.8651647 L3.14394256,5.04801561 C3.52312975,5.02808979 3.86416859,4.98823815 3.86416859,4.98823815 C4.20305928,4.94809022 4.16305906,4.44972248 3.82394616,4.46957423 C3.82394616,4.46957423 2.80475558,4.54957381 2.14660395,4.54957381 C2.02852925,4.54957381 1.88934333,4.54668493 1.74156477,4.54194422 C2.86690406,2.83350881 4.80113651,1.70529256 6.99996296,1.70529256 C8.638342,1.70529256 10.1302017,2.33173369 11.2498373,3.35765419 C11.222726,3.35602457 11.1962815,3.35261718 11.1683554,3.35261718 C10.5501299,3.35261718 10.1114609,3.89113285 10.1114609,4.46957423 C10.1114609,4.98823815 10.4107217,5.42705065 10.7296864,5.94564049 C10.969021,6.36482346 11.248578,6.90326506 11.248578,7.68133501 C11.248578,8.21992476 11.0413918,8.84503256 10.7696866,9.71584277 L10.1417574,11.8132391 L7.86730089,5.04801561 Z M6.99996296,14.2927074 C6.38218192,14.2927074 5.78595654,14.2021153 5.22195356,14.0362644 L7.11048207,8.54925635 L9.04486267,13.8491542 C9.05760348,13.8802652 9.07323319,13.9089317 9.08989995,13.9358945 C8.43574834,14.1661896 7.73285573,14.2927074 6.99996296,14.2927074 L6.99996296,14.2927074 Z M0.706448182,7.99874074 C0.706448182,7.08630113 0.902152921,6.22015756 1.25141403,5.43749503 L4.25357806,13.6627848 C2.15393732,12.6427902 0.706448182,10.4898387 0.706448182,7.99874074 L0.706448182,7.99874074 Z M6.99996296,0.999 C3.14016476,0.999 0,4.13905746 0,7.99874074 C0,11.8585722 3.14016476,14.999 6.99996296,14.999 C10.8596871,14.999 14,11.8585722 14,7.99874074 C14,4.13905746 10.8596871,0.999 6.99996296,0.999 L6.99996296,0.999 Z" id="wordpress-logo-simplified-cmyk" stroke="none" fill=“currentColor” fill-rule="evenodd"></path>
			</svg></a>
					
									</div><!-- .site-info -->
			</div><!-- .footer-bottom-info -->

		</footer><!-- #colophon -->

	</div><!-- .site-inner -->
</div><!-- #page -->

<!--  -->
	<div style="display:none">
	</div>
<script type='text/javascript'>
/* <![CDATA[ */
var HighlanderComments = {"loggingInText":"Logging In\u2026","submittingText":"Posting Comment\u2026","postCommentText":"Post Comment","connectingToText":"Connecting to %s","commentingAsText":"%1$s: You are commenting using your %2$s account.","logoutText":"Log Out","loginText":"Log In","connectURL":"https:\/\/missilecommand.wordpress.com\/public.api\/connect\/?action=request","logoutURL":"https:\/\/missilecommand.wordpress.com\/wp-login.php?action=logout&_wpnonce=c831ff2c5b","homeURL":"https:\/\/arcadeblogger.com\/","postID":"23443","gravDefault":"","enterACommentError":"Please enter a comment","enterEmailError":"Please enter your email address here","invalidEmailError":"Invalid email address","enterAuthorError":"Please enter your name here","gravatarFromEmail":"This picture will show whenever you leave a comment. Click to customize it.","logInToExternalAccount":"Log in to use details from one of these accounts.","change":"Change","changeAccount":"Change Account","comment_registration":"","userIsLoggedIn":"","isJetpack":"","text_direction":"ltr"};
/* ]]> */
</script>
<script type='text/javascript' src='https://s2.wp.com/_static/??/wp-content/js/jquery/jquery.autoresize.js,/wp-content/mu-plugins/highlander-comments/script.js?m=1479964158j'></script>

	<div id="carousel-reblog-box">
		<form action="#" name="carousel-reblog">
			<textarea id="carousel-reblog-content" name="carousel-reblog-content" placeholder="Add your thoughts here... (optional)"></textarea>
			<label for="carousel-reblog-to-blog-id" id="carousel-reblog-lblogid">Post to</label>
			<select name="carousel-reblog-to-blog-id" id="carousel-reblog-to-blog-id">
						</select>

			<div class="submit">
				<span class="canceltext"><a href="#" class="cancel">Cancel</a></span>
				<input type="submit" name="carousel-reblog-submit" class="button" id="carousel-reblog-submit" value="Reblog Post" />
				<input type="hidden" id="carousel-reblog-blog-id" value="3810034" />
				<input type="hidden" id="carousel-reblog-blog-url" value="https://arcadeblogger.com" />
				<input type="hidden" id="carousel-reblog-blog-title" value="The Arcade Blogger" />
				<input type="hidden" id="carousel-reblog-post-url" value="" />
				<input type="hidden" id="carousel-reblog-post-title" value="" />
			</div>

			<input type="hidden" id="_wpnonce" name="_wpnonce" value="1e434ffa15" /><input type="hidden" name="_wp_http_referer" value="/2017/12/22/2017-review-free-to-watch-arcade-movies/" />		</form>

		<div class="arrow"></div>
	</div>

	<script type="text/javascript">
		window.WPCOM_sharing_counts = {"https:\/\/arcadeblogger.com\/2017\/12\/22\/2017-review-free-to-watch-arcade-movies\/":23443};
	</script>
		<script type="text/javascript">
			var windowOpen;
		jQuery(document).on( 'ready post-load', function(){
			jQuery( 'a.share-facebook' ).on( 'click', function() {
				if ( 'undefined' !== typeof windowOpen ){ // If there's another sharing window open, close it.
					windowOpen.close();
				}
				windowOpen = window.open( jQuery(this).attr( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
				return false;
			});
		});
		</script>
					<div id="fb-root"></div>
			<script>(function(d, s, id) { var js, fjs = d.getElementsByTagName(s)[0]; if (d.getElementById(id)) return; js = d.createElement(s); js.id = id; js.src = '//connect.facebook.net/en_US/sdk.js#xfbml=1&appId=249643311490&version=v2.3'; fjs.parentNode.insertBefore(js, fjs); }(document, 'script', 'facebook-jssdk'));</script>
			<script>
			jQuery( document.body ).on( 'post-load', function() {
				if ( 'undefined' !== typeof FB ) {
					FB.XFBML.parse();
				}
			} );
			</script>
						<script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0],p=/^http:/.test(d.location)?'http':'https';if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src=p+'://platform.twitter.com/widgets.js';fjs.parentNode.insertBefore(js,fjs);}}(document, 'script', 'twitter-wjs');</script>
			<script type="text/javascript" src="//platform.tumblr.com/v1/share.js"></script>					<script type="text/javascript">
				// Pinterest shared resources
				var s = document.createElement("script");
				s.type = "text/javascript";
				s.async = true;
				s.setAttribute('data-pin-hover', true);				s.src = window.location.protocol + "//assets.pinterest.com/js/pinit.js";
				var x = document.getElementsByTagName("script")[0];
				x.parentNode.insertBefore(s, x);
				// if 'Pin it' button has 'counts' make container wider
				jQuery(window).load( function(){ jQuery( 'li.share-pinterest a span:visible' ).closest( '.share-pinterest' ).width( '80px' ); } );
			</script>
		<link rel='stylesheet' id='all-css-0-3' href='https://s2.wp.com/_static/??-eJxty0sKgCAQANALZYOg1SY6i0xDaP5w1K4fLdq5ffDgyQJTrBQrhCayb5eNDIU4p8i2k+j2pDSQGZknGHc0JTUmD45qNniLH750hF2qTepVarW4F6ZUMAU=?cssminify=yes' type='text/css' media='all' />
<!--[if lte IE 8]>
<link rel='stylesheet' id='jetpack-carousel-ie8fix-css'  href='https://s1.wp.com/wp-content/mu-plugins/carousel/jetpack-carousel-ie8fix.css?m=1412618825h&#038;ver=20121024' type='text/css' media='all' />
<![endif]-->
<script type='text/javascript'>
/* <![CDATA[ */
var comment_like_text = {"loading":"Loading..."};
/* ]]> */
</script>
<script type='text/javascript'>
/* <![CDATA[ */
var actionbardata = {"siteID":"3810034","siteName":"The Arcade Blogger","siteURL":"https:\/\/arcadeblogger.com","icon":"<img alt='' src='https:\/\/secure.gravatar.com\/blavatar\/b7892ea414bb17d4568669c49151505c?s=50&d=https%3A%2F%2Fs1.wp.com%2Fi%2Flogo%2Fwpcom-gray-white.png' class='avatar avatar-50' height='50' width='50' \/>","canManageOptions":"","canCustomizeSite":"","isFollowing":"","themeSlug":"pub\/dyad-2","signupURL":"https:\/\/wordpress.com\/start\/","loginURL":"https:\/\/missilecommand.wordpress.com\/wp-login.php?redirect_to=https%3A%2F%2Farcadeblogger.com%2F2017%2F12%2F22%2F2017-review-free-to-watch-arcade-movies%2F","themeURL":"https:\/\/wordpress.com\/theme\/dyad-2\/","xhrURL":"https:\/\/arcadeblogger.com\/wp-admin\/admin-ajax.php","nonce":"75184159fe","isSingular":"1","isFolded":"","isLoggedIn":"","isMobile":"","subscribeNonce":"<input type=\"hidden\" id=\"_wpnonce\" name=\"_wpnonce\" value=\"e7291e5af0\" \/>","referer":"https:\/\/arcadeblogger.com\/2017\/12\/22\/2017-review-free-to-watch-arcade-movies\/","canFollow":"1","feedID":"46285485","statusMessage":"","customizeLink":"https:\/\/missilecommand.wordpress.com\/wp-admin\/customize.php?url=https%3A%2F%2Fmissilecommand.wordpress.com%2F2017%2F12%2F22%2F2017-review-free-to-watch-arcade-movies%2F","postID":"23443","shortlink":"https:\/\/wp.me\/pfZaa-667","canEditPost":"","editLink":"https:\/\/wordpress.com\/post\/arcadeblogger.com\/23443","statsLink":"https:\/\/wordpress.com\/stats\/post\/23443\/arcadeblogger.com","i18n":{"view":"View site","follow":"Follow","following":"Following","edit":"Edit","login":"Log in","signup":"Sign up","customize":"Customize","report":"Report this content","themeInfo":"Get theme: Dyad 2","shortlink":"Copy shortlink","copied":"Copied","followedText":"New posts from this site will now appear in your <a href=\"https:\/\/wordpress.com\/\">Reader<\/a>","foldBar":"Collapse this bar","unfoldBar":"Expand this bar","editSubs":"Manage subscriptions","viewReader":"View site in Reader","viewReadPost":"View post in Reader","subscribe":"Sign me up","enterEmail":"Enter your email address","followers":"Join 625 other followers","alreadyUser":"Already have a WordPress.com account? <a href=\"https:\/\/missilecommand.wordpress.com\/wp-login.php?redirect_to=https%3A%2F%2Farcadeblogger.com%2F2017%2F12%2F22%2F2017-review-free-to-watch-arcade-movies%2F\">Log in now.<\/a>","stats":"Stats"}};
/* ]]> */
</script>
<script type='text/javascript'>
/* <![CDATA[ */
var jetpackCarouselStrings = {"widths":[370,700,1000,1200,1400,2000],"is_logged_in":"","lang":"en","ajaxurl":"https:\/\/arcadeblogger.com\/wp-admin\/admin-ajax.php","nonce":"6fdb6225bc","display_exif":"1","display_geo":"1","single_image_gallery":"1","single_image_gallery_media_file":"","background_color":"black","comment":"Comment","post_comment":"Post Comment","write_comment":"Write a Comment...","loading_comments":"Loading Comments...","download_original":"View full size <span class=\"photo-size\">{0}<span class=\"photo-size-times\">\u00d7<\/span>{1}<\/span>","no_comment_text":"Please be sure to submit some text with your comment.","no_comment_email":"Please provide an email address to comment.","no_comment_author":"Please provide your name to comment.","comment_post_error":"Sorry, but there was an error posting your comment. Please try again later.","comment_approved":"Your comment was approved.","comment_unapproved":"Your comment is in moderation.","camera":"Camera","aperture":"Aperture","shutter_speed":"Shutter Speed","focal_length":"Focal Length","comment_registration":"0","require_name_email":"1","login_url":"https:\/\/missilecommand.wordpress.com\/wp-login.php?redirect_to=https%3A%2F%2Farcadeblogger.com%2F2017%2F12%2F22%2F2017-review-free-to-watch-arcade-movies%2F","blog_id":"3810034","local_comments_commenting_as":"<fieldset><label for=\"email\">Email (Required)<\/label> <input type=\"text\" name=\"email\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-email-field\" \/><\/fieldset><fieldset><label for=\"author\">Name (Required)<\/label> <input type=\"text\" name=\"author\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-author-field\" \/><\/fieldset><fieldset><label for=\"url\">Website<\/label> <input type=\"text\" name=\"url\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-url-field\" \/><\/fieldset>","reblog":"Reblog","reblogged":"Reblogged","reblog_add_thoughts":"Add your thoughts here... (optional)","reblogging":"Reblogging...","post_reblog":"Post Reblog","stats_query_args":"blog=3810034&v=wpcom&tz=0&user_id=0&subd=missilecommand","is_public":"1","reblog_enabled":""};
/* ]]> */
</script>
<script type='text/javascript'>
/* <![CDATA[ */
var sharing_js_options = {"lang":"en","counts":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://s1.wp.com/_static/??-eJyVUttOwzAM/SHSDMZAPCA+BbmJ27rNbXHSsb8n1VhVoFTsydbxOb4cWZ6CUN4ldEn2LDWOpDB8VD3fyUXJZhFMbsmxNDQgy2PGjB04bTBukJW3tkDiIuondS35RAFvEX0DfgpTh7bQQq6lPoMWD5PCwUgtJPLuX3QeKJTubhCNV5lFQ7MD5JTJ+rIHWWiRjQeNurLk1jgW2Lt4XpY3R7fG12A23ABdWoka4tQ6YSyZ8CPGSNPEGbuxQ4qghl9eLkVqcm8SzdkGOyIH75hGFGPZy68gfxnGYR3vy4vF81eolqy1l4HoM6ORPaZQLhNXYOvCgdhiEvtqJ9/LZNn4aDf4wXMSjQGKkjuI5NprLKI3+3p/2L3snx8PT4f+E+eIPm8='></script>
<script type="text/javascript">
// <![CDATA[
(function() {
try{
  if ( window.external &&'msIsSiteMode' in window.external) {
    if (window.external.msIsSiteMode()) {
      var jl = document.createElement('script');
      jl.type='text/javascript';
      jl.async=true;
      jl.src='/wp-content/plugins/ie-sitemode/custom-jumplist.php';
      var s = document.getElementsByTagName('script')[0];
      s.parentNode.insertBefore(jl, s);
    }
  }
}catch(e){}
})();
// ]]>
</script>		<iframe src='https://widgets.wp.com/likes/master.html?ver=20170206#ver=20170206' scrolling='no' id='likes-master' name='likes-master' style='display:none;'></iframe>
		<div id='likes-other-gravatars'><div class="likes-text"><span>%d</span> bloggers like this:</div><ul class="wpl-avatars sd-like-gravatars"></ul></div>
<script src="//stats.wp.com/w.js?56" type="text/javascript" async defer></script>
<script type="text/javascript">
_tkq = window._tkq || [];
_stq = window._stq || [];
_tkq.push(['storeContext', {'blog_id':'3810034','blog_tz':'0','user_lang':'en','blog_lang':'en','user_id':'0'}]);
_stq.push(['view', {'blog':'3810034','v':'wpcom','tz':'0','user_id':'0','post':'23443','subd':'missilecommand'}]);
_stq.push(['extra', {'crypt':'UE40eW5QN0p8M2Y/RE1TaVhzUzFMbjdWNHpwZGhTayxPSUFCMGRVYVNrSFguN3FwSmQ5RGtNX3VQcj1yVzhiflM1THQtLGFdQ2toOXYlaVQwL0llST1WRWdyUVNVVy5MS0w5NCtJLS5iR1FXcE5ZVmMlUT1sbms9MnwyQ3lUdTB5TlkzU05acy9NTFo3WUl1RzNXeTBuLFtXM1s5akVULmNPVmJMakZiYlNSMFlTOUdwPVRkMWt2N2JbSCZmb3ZGczFlWWNEcFhlOUZWdVpNRDBZVlZpfC1afktyLjlSUDFiaVUlZFlDJjVtfndVOTlCLGFOcWNlYngtRWZhQ3pHeTNqSy9vZmlZWlV6ampwUFJRbXl0SGNwbXFtdWJXWDYsUFs4dU1tT3Q3XUk4V1IzUG5aMjNVN1g='}]);
_stq.push([ 'clickTrackerInit', '3810034', '23443' ]);
	</script>
<noscript><img src="https://pixel.wp.com/b.gif?v=noscript" style="height:0px;width:0px;overflow:hidden" alt="" /></noscript>
<script>
if ( 'object' === typeof wpcom_mobile_user_agent_info ) {

	wpcom_mobile_user_agent_info.init();
	var mobileStatsQueryString = "";
	
	if( false !== wpcom_mobile_user_agent_info.matchedPlatformName )
		mobileStatsQueryString += "&x_" + 'mobile_platforms' + '=' + wpcom_mobile_user_agent_info.matchedPlatformName;
	
	if( false !== wpcom_mobile_user_agent_info.matchedUserAgentName )
		mobileStatsQueryString += "&x_" + 'mobile_devices' + '=' + wpcom_mobile_user_agent_info.matchedUserAgentName;
	
	if( wpcom_mobile_user_agent_info.isIPad() )
		mobileStatsQueryString += "&x_" + 'ipad_views' + '=' + 'views';

	if( "" != mobileStatsQueryString ) {
		new Image().src = document.location.protocol + '//pixel.wp.com/g.gif?v=wpcom-no-pv' + mobileStatsQueryString + '&baba=' + Math.random();
	}
	
}
</script>
</body>
</html>
